Remove watermark Windows 10

In CMD as Administrator

bcdedit -set TESTSIGNING OFF
 

ROracle in RStudio Server Ubuntu 18.04

Install Oracle Insta Client

https://download.oracle.com/otn_software/linux/instantclient/19800/instantclient-basic-linux.x64-19.8.0.0.0dbru.zip

https://download.oracle.com/otn_software/linux/instantclient/19800/instantclient-sdk-linux.x64-19.8.0.0.0dbru.zip

Create directory

mkdir /opt/oracle

Unzip the contents of both files

Install AIO

sudo apt install libaio1

Execu script

sudo sh -c "echo /opt/oracle/instantclient_19_3 > \
      /etc/ld.so.conf.d/oracle-instantclient.conf"
  sudo ldconfig

Build ROracle

Sys.setenv(
  'ORACLE_HOME' = '/opt/oracle/instantclient_19_8',
  'OCI_LIB64'   = '/opt/oracle/instantclient_19_8'
)
install.packages("ROracle", type="source")

library("ROracle")

Test your script

library(ROracle)
drv <- dbDriver("Oracle")
host <- "localhost"
port <- 1521
service <- "ids"
drv <- dbDriver("Oracle")

connect.string <- paste(
  
  "(DESCRIPTION=",
  
  "(ADDRESS=(PROTOCOL=tcp)(HOST=", host, ")(PORT=", port, "))",
  
  "(CONNECT_DATA=(SERVICE_NAME=", service, ")))", sep = "")

con <- dbConnect(drv, username = "user", password = "pass", dbname = connect.string)

table_results <- dbGetQuery(con,"select * from table")
 

Remove old Kernels Ubuntu 18.04

Copy the text, this is one line.

echo $(dpkg --list | grep linux-image | awk '{ print $2 }' | sort -V | sed -n '/'`uname -r`'/q;p') $(dpkg --list | grep linux-headers | awk '{ print $2 }' | sort -V | sed -n '/'"$(uname -r | sed "s/\([0-9.-]*\)-\([^0-9]\+\)/\1/")"'/q;p') | xargs sudo apt-get -y purge
 

OpenVPN NAT on client to access LAN

Enable IP Forwarding

Then run

/sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
/sbin/iptables -A FORWARD -i eth0 -o tun0 -m state --state RELATED,ESTABLISHED -j ACCEPT
/sbin/iptables -A FORWARD -i tun0 -o eth0 -j ACCEPT
 

Relay Bridge OPENWRT

Start with

opkg update
opkg install relayd
vi /etc/init.d/relayd enable /etc/config/network

config interface 'loopback' 
	option ifname 'lo' 
	option proto 'static' 
	option ipaddr '127.0.0.1' 
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd37:7ec5:def1::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '10.0.0.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'

config interface 'wwan'
	option proto 'static'
	option ipaddr '10.0.0.2' #IP WWAN match you main router network 192.168.x.254
	option netmask '255.255.255.0'
	option gateway '10.0.0.1' #your main router's IP

config interface 'stabridge'
option proto 'relay'
option network 'lan wwan'
option ipaddr '10.0.0.2' #Same IP as in WWAN

vi /etc/config/wireless

config wifi-device radio0
	option type mac80211
	option channel 11 	# Original channel of main router
	option hwmode 11g
	option path 'pci0000:00/0000:00:00.0'
	option htmode HT20
	option disabled 0

config wifi-iface
	option ssid chang_1 	# SSID of main router
	option encryption psk2	# Set wep, psk or psk2 for WEP, WPA or WPA2
	option device radio0
	option mode sta
	option network wwan
	option key lechangue	# Main router password

config wifi-iface
	option device radio0
	option mode ap
	option ssid chang_2	# SSID of repeater router
	option encryption psk
	option key lechangue	# Repeater router password
	option network lan

vi /etc/config/dhcp

config dhcp lan
	option interface lan
	option start 100
	option limit 150
	option leasetime 12h
	option ignore 1

config dhcp wan
	option interface wan
	option ignore 1

Stop firewall:

/etc/init.d/firewall stop
/etc/init.d/firewall disable

 

Sound not working in Porteus Linux

If you have issues with the sound card try creating a file in /etc/asound.conf

defaults.pcm.card 1
defaults.ctl.card 1
 

Chromium OS installation step by step

I have been struggling for two day to make the files app work, here is the solution I found, step by step so new users are able to execute it.

Download a fresh image from http://arnoldthebat.co.uk/wordpress/chromium-os/

I tried October 13 daily build 64 bits.

Load the image into an USB as explained in the page.

Boot chromium from USB and configure the firts run.

Once you are logged in go to the next page.

http://www.chromium.org/developers/how-tos/api-keys

Follow the instructions to generate your keys.

Then go to the developer console apis list and make sure you have the following apis enabled.

Drive API
Drive SDK.
Google Maps Geolocation API.
Google Now For Chrome API. 

Open a new Crosh screen Ctrl + Alt + T in chromium browser.

Type: shell.

Type : sudo su.

And enter the password usually “password” without quotes.

Mount your system as read write.

Type: mount -o remount,rw /

Type: cd /etc

Type: vi chrome_dev.conf

Go to the first line and insert your keys (fake ones used):

GOOGLE_API_KEY=AAA

GOOGLE_DEFAULT_CLIENT_ID=BBB

GOOGLE_DEFAULT_CLIENT_SECRET=CCC.

Be careful as VI is very tricky to use, once the data is correct save the file, using ESC wq and enter, if you have issues saving find in google on how to use VI.

Once the file is saved go to the bottom right of the screen and click on your user picture and sign out, once the system ui restart login, it will say that you need to login again in order to update your credentials, once you login again, the system will be able to use the files APP.

After this I usually load the plugins like flash and other unsupported files.

What worked for me is following the instructions in.

https://github.com/sixsixfive/chromiumos.

The script asks for Keys, but I already saved them in the file, So maybe we can save some of the steps discussed above using the functionality in the script, If someone can try that it will be great as we will avoid the use of the shell.

Please share your experience with the instructions I have provided, Im happy to be able to share something with the community.

 

Migrating to Lucid Lynx (10.04 LTS) – coLinux

Once the upgrade is completed, add the following to /etc/fstab (before rebooting):

dev /dev devtmpfs rw 0 0

Sometimes you have to replace devtmpfs with just tmpfs in the line above.

There may be plymouth warnings on the console at the next reboot. Disable those by running:

cd /etc/init for i in plymouth*; do mv $i $i.disabled; done
 

Create an upstart script for uTorrent

To create an upstart script for uTorrent, move all the uTorrent files to the /home/yourusername/.utorrent folder, then run the following command:

$sudo nano /etc/init/utorrent.conf

description “utorrent startup script”

 
start on (local-filesystems and started dbus and stopped udevtrigger)
stop on runlevel [016]
script
cd /home/yourusername/.utorrent
exec su yourusername -c “/home/yourusername/.utorrent/utserver”
end script

 

 

$sudo ln -s /lib/init/upstart-job /etc/init.d/utorrent

 

WPA Ubuntu 10.04

Install wpa supplicant package:

$ sudo apt-get install wpasupplicant

Configure network ESSID and passphrase.
In this example I use ESSID ‘yantoknuk-singtel’ and passphrase ‘ngumbahkucing’.

$ wpa_passphrase yantoknuk-singtel
# reading passphrase from stdin

After that, type in your passphrase right below the text ‘# reading passphrase from stdin’.

# reading passphrase from stdin
ngumbahkucing
network={
ssid=”yantoknuk-singtel”
#psk=”ngumbahkucing”
psk=1e6eb493adf24740e2d3e98759b8b985e69f0bb939931c19400ceeecb61788e1
}

Edit or create /etc/wpa_supplicant.conf:

$ sudo nano /etc/wpa_supplicant.conf

And then type in the following lines which is produced by wpa_passphrase before:

network={
ssid=”yantoknuk-singtel”
#psk=”ngumbahkucing”
psk=1e6eb493adf24740e2d3e98759b8b985e69f0bb939931c19400ceeecb61788e1
}

Save and exit nano.
To test the configuration, execute this:

$ sudo wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -Dwext

If it’s successful you should see something like the following:

Trying to associate with 00:ff:00:1e:a7:7d (SSID=’yantoknuk-singtel’ freq=0 MHz)
Associated with 00:ff:00:1e:a7:7d
WPA: Key negotiation completed with 00:ff:00:1e:a7:7d [PTK=TKIP GTK=TKIP]

It’s finish. Your computer is now associated / connected to the access point.
To make it autorun on boot, add in these lines to /etc/network/interfaces:
$ sudo nano /etc/network/interfaces

And add the following lines:

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-conf /etc/wpa_supplicant.conf