Relay Bridge OPENWRT

Start with

opkg update
opkg install relayd
vi /etc/init.d/relayd enable /etc/config/network

config interface 'loopback' 
	option ifname 'lo' 
	option proto 'static' 
	option ipaddr '127.0.0.1' 
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd37:7ec5:def1::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '10.0.0.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'

config interface 'wwan'
	option proto 'static'
	option ipaddr '10.0.0.2' #IP WWAN match you main router network 192.168.x.254
	option netmask '255.255.255.0'
	option gateway '10.0.0.1' #your main router's IP

config interface 'stabridge'
option proto 'relay'
option network 'lan wwan'
option ipaddr '10.0.0.2' #Same IP as in WWAN

vi /etc/config/wireless

config wifi-device radio0
	option type mac80211
	option channel 11 	# Original channel of main router
	option hwmode 11g
	option path 'pci0000:00/0000:00:00.0'
	option htmode HT20
	option disabled 0

config wifi-iface
	option ssid chang_1 	# SSID of main router
	option encryption psk2	# Set wep, psk or psk2 for WEP, WPA or WPA2
	option device radio0
	option mode sta
	option network wwan
	option key lechangue	# Main router password

config wifi-iface
	option device radio0
	option mode ap
	option ssid chang_2	# SSID of repeater router
	option encryption psk
	option key lechangue	# Repeater router password
	option network lan

vi /etc/config/dhcp

config dhcp lan
	option interface lan
	option start 100
	option limit 150
	option leasetime 12h
	option ignore 1

config dhcp wan
	option interface wan
	option ignore 1

Stop firewall:

/etc/init.d/firewall stop
/etc/init.d/firewall disable

 

Chromium OS installation step by step

I have been struggling for two day to make the files app work, here is the solution I found, step by step so new users are able to execute it.

Download a fresh image from http://arnoldthebat.co.uk/wordpress/chromium-os/

I tried October 13 daily build 64 bits.

Load the image into an USB as explained in the page.

Boot chromium from USB and configure the firts run.

Once you are logged in go to the next page.

http://www.chromium.org/developers/how-tos/api-keys

Follow the instructions to generate your keys.

Then go to the developer console apis list and make sure you have the following apis enabled.

Drive API
Drive SDK.
Google Maps Geolocation API.
Google Now For Chrome API. 

Open a new Crosh screen Ctrl + Alt + T in chromium browser.

Type: shell.

Type : sudo su.

And enter the password usually “password” without quotes.

Mount your system as read write.

Type: mount -o remount,rw /

Type: cd /etc

Type: vi chrome_dev.conf

Go to the first line and insert your keys (fake ones used):

GOOGLE_API_KEY=AAA

GOOGLE_DEFAULT_CLIENT_ID=BBB

GOOGLE_DEFAULT_CLIENT_SECRET=CCC.

Be careful as VI is very tricky to use, once the data is correct save the file, using ESC wq and enter, if you have issues saving find in google on how to use VI.

Once the file is saved go to the bottom right of the screen and click on your user picture and sign out, once the system ui restart login, it will say that you need to login again in order to update your credentials, once you login again, the system will be able to use the files APP.

After this I usually load the plugins like flash and other unsupported files.

What worked for me is following the instructions in.

https://github.com/sixsixfive/chromiumos.

The script asks for Keys, but I already saved them in the file, So maybe we can save some of the steps discussed above using the functionality in the script, If someone can try that it will be great as we will avoid the use of the shell.

Please share your experience with the instructions I have provided, Im happy to be able to share something with the community.

 

Create an upstart script for uTorrent

To create an upstart script for uTorrent, move all the uTorrent files to the /home/yourusername/.utorrent folder, then run the following command:

$sudo nano /etc/init/utorrent.conf

description “utorrent startup script”

 
start on (local-filesystems and started dbus and stopped udevtrigger)
stop on runlevel [016]
script
cd /home/yourusername/.utorrent
exec su yourusername -c “/home/yourusername/.utorrent/utserver”
end script

 

 

$sudo ln -s /lib/init/upstart-job /etc/init.d/utorrent

 

WPA Ubuntu 10.04

Install wpa supplicant package:

$ sudo apt-get install wpasupplicant

Configure network ESSID and passphrase.
In this example I use ESSID ‘yantoknuk-singtel’ and passphrase ‘ngumbahkucing’.

$ wpa_passphrase yantoknuk-singtel
# reading passphrase from stdin

After that, type in your passphrase right below the text ‘# reading passphrase from stdin’.

# reading passphrase from stdin
ngumbahkucing
network={
ssid=”yantoknuk-singtel”
#psk=”ngumbahkucing”
psk=1e6eb493adf24740e2d3e98759b8b985e69f0bb939931c19400ceeecb61788e1
}

Edit or create /etc/wpa_supplicant.conf:

$ sudo nano /etc/wpa_supplicant.conf

And then type in the following lines which is produced by wpa_passphrase before:

network={
ssid=”yantoknuk-singtel”
#psk=”ngumbahkucing”
psk=1e6eb493adf24740e2d3e98759b8b985e69f0bb939931c19400ceeecb61788e1
}

Save and exit nano.
To test the configuration, execute this:

$ sudo wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -Dwext

If it’s successful you should see something like the following:

Trying to associate with 00:ff:00:1e:a7:7d (SSID=’yantoknuk-singtel’ freq=0 MHz)
Associated with 00:ff:00:1e:a7:7d
WPA: Key negotiation completed with 00:ff:00:1e:a7:7d [PTK=TKIP GTK=TKIP]

It’s finish. Your computer is now associated / connected to the access point.
To make it autorun on boot, add in these lines to /etc/network/interfaces:
$ sudo nano /etc/network/interfaces

And add the following lines:

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-conf /etc/wpa_supplicant.conf

 

Headless X11VNC

The answer is actually a combination of two separate solutions, each of which did not work separately. I have 10.04 now working headless on two different servers (different MB, Video…) and both are working great.

Step 1. Create a xorg.conf in /etc/X11 with the following. I tried Step 2 without doing this and it failed exactly as it had before.

Section “Device”
Identifier “VNC Device”
Driver “vesa”
EndSection

Section “Screen”
Identifier “VNC Screen”
Device “VNC Device”
Monitor “VNC Monitor”
SubSection “Display”
Modes “1024×768”
EndSubSection
EndSection

Section “Monitor”
Identifier “VNC Monitor”
HorizSync 30-70
VertRefresh 50-75
EndSection

Step 2. Disable KMS for your video card as described here https://wiki.ubuntu.com/X/KernelModeSetting

The jist is to know which video card manufacturer you have and use the command line entry below it to create the appropriate kms.conf file with the line “options…modeset=0” line in it. If you have access to the GUI you could just are easily create/modify the file and put the “options…modeset=0” in as appropriate.

The following are input into the terminal windows as a line command.

# ATI Radeon:
echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

# Intel:
echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

# Nvidia (this should revert you to using -nv or -vesa):
echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

Step 3. Reboot…Putty In…startx…GTG!

 

X11VNC Ubuntu 10.04

This is a simple guide on setting up X11VNC on a system running Ubuntu 10.04 in a headless configuration. Good Luck, and YMMV.

1. Terminal > sudo apt-get install x11vnc
OR compile x11vnc from source: http://www.karlrunge.com/x11vnc/

2. Terminal > sudo nano /etc/gdm/Init/Default

2.1. Add on the second last line:
/usr/bin/x11vnc -xkb -rfbauth /etc/x11vnc/passwd -o /etc/x11vnc/log -bg -forever
OR if you compiled from source, add the following line:
/usr/local/bin/x11vnc -xkb -rfbauth /etc/x11vnc/passwd -o /etc/x11vnc/log -bg -forever

2.2. Terminal > sudo mkdir /etc/x11vnc

2.3. Terminal > sudo touch /etc/x11vnc/log

2.4. Terminal > sudo x11vnc -storepasswd /etc/x11vnc/passwd
Follow the commands to store your password. Alternatively, if you do not wish to use a password, do not run this line and remove the -rfbauth /etc/x11vnc/passwd section from /etc/gdm/Init/Default

3. Terminal > sudo restart gdm

 

Iniciar VNC automaticamente en Ubuntu

Para tener un VNC que inicie automaticamente con el perfil de usuario deseado y con la resolucion que uno elija, hay que hacer un archivo llamado vnc en la ruta /etc/init.d con el siguiente contenido:

#!/bin/sh -e
### BEGIN INIT INFO
# Provides:          vncserver
# Required-Start:    networking
# Default-Start:     S
# Default-Stop:      0 6
### END INIT INFO

PATH=”$PATH:/usr/X11R6/bin/”

# The Username:Group that will run VNC
export USER=”mythtv”
#${RUNAS}

# The display that VNC will use
DISPLAY=”1″

# Color depth (between 8 and 32)
DEPTH=”16″

# The Desktop geometry to use.
#GEOMETRY=”<WIDTH>x<HEIGHT>”
#GEOMETRY=”800×600″
GEOMETRY=”1024×768″
#GEOMETRY=”1280×1024″

# The name that the VNC Desktop will have.
NAME=”my-vnc-server”

OPTIONS=”-name ${NAME} -depth ${DEPTH} -geometry ${GEOMETRY} :${DISPLAY}”

. /lib/lsb/init-functions

case “$1” in
start)
log_action_begin_msg “Starting vncserver for user ‘${USER}’ on localhost:${DISPLAY}”
su ${USER} -c “/usr/bin/vncserver ${OPTIONS}”
;;

stop)
log_action_begin_msg “Stoping vncserver for user ‘${USER}’ on localhost:${DISPLAY}”
su ${USER} -c “/usr/bin/vncserver -kill :${DISPLAY}”
;;

restart)
$0 stop
$0 start
;;
esac

exit 0

Despues ejecutamos lo siguiente, para que arranque automaticamente con el sistema, recuerda de hacer ejecutable el archivo vnc con el comando chmod +x vnc

update-rc.d vncserver defaults

 

Buscar texto en archivos recursivamente

El dia  de hoy al tratar de modificar el template del sitio estaba buscando el texto que aparece en la forma de busqueda, estaba en ingles y la queria poner en español.

 

Gracias a linux, esto es muy sencillo basta con teclear

grep -r “search this site” *

Con esto el sistema buscara recursivamente por el string dentro de todos los archivos